summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:57:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:09 +0100
commitaae42f41669ae7263dba6fe6f66f688f1d0c4be8 (patch)
treeaa40e9b958208863df248cd019aaf212e68920c3 /dev-python/flit
parentdev-python/flit_core: Remove old (diff)
downloadgentoo-aae42f41669ae7263dba6fe6f66f688f1d0c4be8.tar.gz
gentoo-aae42f41669ae7263dba6fe6f66f688f1d0c4be8.tar.bz2
gentoo-aae42f41669ae7263dba6fe6f66f688f1d0c4be8.zip
dev-python/flit: Bump to 3.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flit')
-rw-r--r--dev-python/flit/Manifest1
-rw-r--r--dev-python/flit/flit-3.7.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/flit/Manifest b/dev-python/flit/Manifest
index 39f7d487b562..5eef2dd830a0 100644
--- a/dev-python/flit/Manifest
+++ b/dev-python/flit/Manifest
@@ -1,3 +1,4 @@
DIST flit-3.5.1.tar.gz 122689 BLAKE2B 49be251df549783114c6758fa688d00fe18ed88d215f91783ce78eda722ee3d8578d83781a1a5c9ee61dd001c82df010c879dc742a1829c2ba8bcf5edb930556 SHA512 00e884774c7f59dfb54d6db09f65ac0ed47f1dd23872d6913f3a41de7242fb3829b2edacd03d08e080635c0a515521333aa74e6d26a2faa5fc02e56454b2b37a
DIST flit-3.6.0.tar.gz 133365 BLAKE2B c4170eeded3c15a93c8e89b9483459247228136bc5ff32c6edb8cd9a4b5c3171fe381d0a1b4e325ed863457c2bce476efe3276455d5b9e4279a702dd35ed4512 SHA512 6506ecc73f9e0373e84b5b90a3d567f1edad6d95561886ff1f08f37addfc39006e75ab199c376a7d18452f6b8e2cbdd9e8f59a1fc96037702c3c682dc0b5a757
DIST flit-3.7.0.tar.gz 136190 BLAKE2B 1d5f1fc64e5c4fbdbb34f515b3ba5f87364a56716251f8e2da7fe9912ca8c547e0a3e1001cd65c594e23c38478341908f952fc9fed3e42020179ce90f3910b92 SHA512 6d96d69502bd703b62ac9fe8723fdf737f73d4a77c53e13c0b888d40ade96617c3d3cbf09013121c049c5c28db496d554fe217b03de9abfe28971586c8dc8d32
+DIST flit-3.7.1.tar.gz 136642 BLAKE2B b94f8bbe00c2c5fb28bddbdcf240255ed53ec3b24d2eab1a33e37261cf32a92a0171ea01ad1488384c15f46acbf84d47c4679b318932a3ee78f22c1d161156b0 SHA512 336e81b034da2f38d7decb32c8961ce62d30f6fd2cb4778b09c956eb400277673d4c94cd57cf08fa7f115f8836aadb0469197d0096f833da9317db8a4f75baed
diff --git a/dev-python/flit/flit-3.7.1.ebuild b/dev-python/flit/flit-3.7.1.ebuild
new file mode 100644
index 000000000000..5b1ac297822c
--- /dev/null
+++ b/dev-python/flit/flit-3.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simplified packaging of Python modules"
+HOMEPAGE="https://github.com/pypa/flit https://flit.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/flit_core-${PV}[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomli-w[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ sys-apps/grep
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # requires Internet
+ tests/test_config.py::test_invalid_classifier
+ # failing due to Gentoo pip patches
+ tests/test_install.py::InstallTests::test_install_data_dir
+ tests/test_install.py::InstallTests::test_install_module_pep621
+ tests/test_install.py::InstallTests::test_symlink_data_dir
+ tests/test_install.py::InstallTests::test_symlink_module_pep621
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/pygments-github-lexers \
+
+src_prepare() {
+ # make sure system install is used
+ rm -r flit_core || die
+ distutils-r1_src_prepare
+}