summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-11 12:56:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-11 13:59:45 +0200
commit611659039f019e248b08c106f21e51e9cfcb5595 (patch)
treee19c74913b6999db700f741f9014f044941d090c /dev-python/fonttools
parentdev-python/cbor2: Remove old (diff)
downloadgentoo-611659039f019e248b08c106f21e51e9cfcb5595.tar.gz
gentoo-611659039f019e248b08c106f21e51e9cfcb5595.tar.bz2
gentoo-611659039f019e248b08c106f21e51e9cfcb5595.zip
dev-python/fonttools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fonttools')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.51.0.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index 92e85be2ada5..47f0caba5947 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,3 +1,2 @@
-DIST fonttools-4.51.0.gh.tar.gz 3826324 BLAKE2B 84485874ce373ef759746104f8c0593d63e2955427a1606404e56ae006342fef39e3fe9468d85b974741ae26a8cceba23ea46e33fff0e2648c154074b01b5eac SHA512 3a9984b56a8ed1e918781c8503dd8901276ae7e20659777ff0a9bf799a42b4ec112a6cfd31deb81f73f7f19c03145a66962187fb243b2580db9d3ef7011d3d82
DIST fonttools-4.53.0.gh.tar.gz 3847778 BLAKE2B 31cf6e495441aeee90f96d6f96b9eedb581f3ee7e5e6f00f7df41547738e7da24d58b4aeac691c44961f842bbf347b32965b052d84ced88c7ade9c0d95c0367a SHA512 f810c428680c4203af3450c4a4b3a1d0f3f5e06ec7d7aac65e1e4aadf5d1e98f9efa5fed75388c8b0a0dcef5094d9b0586c0a71587360bafc91ad683a961698a
DIST fonttools-4.53.1.gh.tar.gz 3850978 BLAKE2B 9c6b5af2cbde939b82043e29ffbbb23434c7b4bb7d7ce68385de701cdf97792bfb58b39acf5e0843493d4b4c3b70f76df6194c9a2ba4f4dfa7ec46155b9f8ce0 SHA512 c51a439c4c760bc929359ff3010612d00280ff1bfa8e6dd5248f181b3244239b82089727b4b6c81594fec57407f4c20f95497e0e26fe0e75fde30f8680022d07
diff --git a/dev-python/fonttools/fonttools-4.51.0.ebuild b/dev-python/fonttools/fonttools-4.51.0.ebuild
deleted file mode 100644
index b2122f7e18d7..000000000000
--- a/dev-python/fonttools/fonttools-4.51.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
-HOMEPAGE="
- https://github.com/fonttools/fonttools/
- https://pypi.org/project/fonttools/
-"
-SRC_URI="
- https://github.com/fonttools/fonttools/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-IUSE="+native-extensions"
-
-RDEPEND="
- >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
-"
-BDEPEND="
- native-extensions? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- )
- test? (
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- app-arch/zopfli
- )
-"
-
-EPYTEST_XDIST=1
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # When dev-python/pytest-shutil is installed, we get weird import errors.
- # This is due to incomplete nesting in the Tests/ tree:
- #
- # Tests/feaLib/__init__.py
- # Tests/ufoLib/__init__.py
- # Tests/svgLib/path/__init__.py
- # Tests/otlLib/__init__.py
- # Tests/varLib/__init__.py
- #
- # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
- touch Tests/svgLib/__init__.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- local -x FONTTOOLS_WITH_CYTHON=$(usex native-extensions)
- [[ ${EPYTHON} == pypy3 ]] && FONTTOOLS_WITH_CYTHON=0
- distutils-r1_python_compile
-}
-
-src_test() {
- # virtualx used when matplotlib is installed causing plot module tests to run
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # flaky test
- Tests/ttLib/woff2_test.py::WOFF2ReaderTest::test_get_normal_tables
- )
-
- if [[ ${EPYTHON} == pypy3 ]] &&
- has_version "dev-python/pyxattr[${PYTHON_USEDEP}]" &&
- {
- has_version "<dev-python/pypy3_10-exe-7.3.13_p2" ||
- has_version "<dev-python/pypy3_10-exe-bin-7.3.13_p2"
- }
- then
- EPYTEST_DESELECT+=(
- # affected by a bug in PyPy/pyxattr
- # https://github.com/iustin/pyxattr/issues/41
- Tests/t1Lib/t1Lib_test.py::ReadWriteTest::test_read_with_path
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest \
- -p rerunfailures --reruns=5 \
- Tests fontTools || die -n "Tests failed with ${EPYTHON}"
-}