summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 07:50:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 10:23:14 +0200
commit397665abb0b6cd27f0f705b3d688b3817b5b4dea (patch)
tree9f953eeb6b12c9e4f8841141426d4c36cb9fa4ed /dev-python/funcparserlib/funcparserlib-1.0.1.ebuild
parentdev-python/websocket-client: add 1.4.2 (diff)
downloadgentoo-397665abb0b6cd27f0f705b3d688b3817b5b4dea.tar.gz
gentoo-397665abb0b6cd27f0f705b3d688b3817b5b4dea.tar.bz2
gentoo-397665abb0b6cd27f0f705b3d688b3817b5b4dea.zip
dev-python/funcparserlib: add 1.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/funcparserlib/funcparserlib-1.0.1.ebuild')
-rw-r--r--dev-python/funcparserlib/funcparserlib-1.0.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/funcparserlib/funcparserlib-1.0.1.ebuild b/dev-python/funcparserlib/funcparserlib-1.0.1.ebuild
new file mode 100644
index 000000000000..332f7b6a5ad9
--- /dev/null
+++ b/dev-python/funcparserlib/funcparserlib-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Recursive descent parsing library based on functional combinators"
+HOMEPAGE="https://pypi.org/project/funcparserlib/
+ https://github.com/vlasovskikh/funcparserlib"
+SRC_URI="
+ https://github.com/vlasovskikh/funcparserlib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest