summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-21 16:30:45 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-21 16:32:46 +0100
commit43cf24834fa8821bb2bed899b34c1e49634d0f99 (patch)
tree46404da8583ec3554f6692e9daf500fbb6db48ef /dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild
parentdev-python/humanfriendly: Version Bump (diff)
downloadgentoo-43cf24834fa8821bb2bed899b34c1e49634d0f99.tar.gz
gentoo-43cf24834fa8821bb2bed899b34c1e49634d0f99.tar.bz2
gentoo-43cf24834fa8821bb2bed899b34c1e49634d0f99.zip
dev-python/google-api-python-client: Version Bump
Set correct versions for dependencies Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild
new file mode 100644
index 000000000000..aef0fa73123e
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.5.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://code.google.com/p/google-api-python-client/ https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
+ <dev-python/oauth2client-3[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-0.6[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all(){
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}