summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-08 06:14:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-08 06:14:39 +0100
commit85a2cadeede285035d16ee2ce6cb4ddc866d706b (patch)
tree6112059862c43716e4b2759c8a264c3f1e60d0b7 /dev-python/google-auth
parentdev-python/jsonpickle: Remove old (diff)
downloadgentoo-85a2cadeede285035d16ee2ce6cb4ddc866d706b.tar.gz
gentoo-85a2cadeede285035d16ee2ce6cb4ddc866d706b.tar.bz2
gentoo-85a2cadeede285035d16ee2ce6cb4ddc866d706b.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.14.1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 8352bc0e68cd..4ffef6a28def 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1 @@
-DIST google-auth-2.14.1.tar.gz 220079 BLAKE2B 7e0958bd0f83bb9e47e5ea191a6f90f221630c67638082fdafb2b925e44eb9c68f6b91e86ab8b7869edb70de21c3be44041ded6507c2819754b19b13bd342a0c SHA512 1aec6b7104d71f58d1bc76472b204261eb6fc3030d0ed5f523bb125a9169544bc6266a8ae4573fce28423b689f2efcf57aadafc6c21876824fc17b2a96bbed95
DIST google-auth-2.15.0.tar.gz 221698 BLAKE2B 73decb21ab51889d2f22a2dca9d01f8c7d77a37a5ba186e2fba05bfb7a56f0e5ea0f5c1396c0be527b03e9083e98995e96f0081973e97766fafc6a63946c0015 SHA512 4a564503195e4a96ac2a89bb208c37e434185439533913285ca03a3627f28e641a99224ae285ced84050fdc6073e075b1ba288e9a9c18d3e6adf70509b5ee68b
diff --git a/dev-python/google-auth/google-auth-2.14.1.ebuild b/dev-python/google-auth/google-auth-2.14.1.ebuild
deleted file mode 100644
index 37c2ffef06a9..000000000000
--- a/dev-python/google-auth/google-auth-2.14.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}