summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 15:09:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 15:09:24 +0100
commitc7c0625e8443976be8aff302f9e3955d4e403298 (patch)
treef0d6c160bf2f52e626a11c17ec04d7045a17f7e9 /dev-python/google-auth
parentdev-games/openscenegraph: require dot for docs (diff)
downloadgentoo-c7c0625e8443976be8aff302f9e3955d4e403298.tar.gz
gentoo-c7c0625e8443976be8aff302f9e3955d4e403298.tar.bz2
gentoo-c7c0625e8443976be8aff302f9e3955d4e403298.zip
dev-python/google-auth: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.15.0-r1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 34d225fafe9a..2157f2fea959 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1 @@
-DIST google-auth-2.15.0.tar.gz 221698 BLAKE2B 73decb21ab51889d2f22a2dca9d01f8c7d77a37a5ba186e2fba05bfb7a56f0e5ea0f5c1396c0be527b03e9083e98995e96f0081973e97766fafc6a63946c0015 SHA512 4a564503195e4a96ac2a89bb208c37e434185439533913285ca03a3627f28e641a99224ae285ced84050fdc6073e075b1ba288e9a9c18d3e6adf70509b5ee68b
DIST google-auth-2.16.0.tar.gz 223336 BLAKE2B 9dbd54bdf072dacdf728f6fc34931f153dd409e3e1b92e37ed652a1db39d5380b7e66bd196cb1192f75234b2317518a443f8f515bc9135f553e6c9f1116fc606 SHA512 dbeff00089a410c6702e2bd704968c7392809dc217b3f511b62429a11649e4b0607a41622d2753bed9e511368b1c32086b23df66ec915e07a1dd4f32471e025d
diff --git a/dev-python/google-auth/google-auth-2.15.0-r1.ebuild b/dev-python/google-auth/google-auth-2.15.0-r1.ebuild
deleted file mode 100644
index 2dc5b30afbe8..000000000000
--- a/dev-python/google-auth/google-auth-2.15.0-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="
- https://github.com/googleapis/google-auth-library-python/
- https://pypi.org/project/google-auth/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/grpcio[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/moto[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pyu2f[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # these are compatibility tests with oauth2client
- # disable them to unblock removal of that package
- tests/test__oauth2client.py
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}