summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-23 21:51:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-23 22:30:06 +0100
commit11bbfa1b1335ea5dab99fc1aa8378210c5de0655 (patch)
tree87d32ee4cb72cc72997fff54bf0b652e1a2f05d0 /dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild
parentdev-python/autobahn: Bump to 22.2.1 (diff)
downloadgentoo-11bbfa1b1335ea5dab99fc1aa8378210c5de0655.tar.gz
gentoo-11bbfa1b1335ea5dab99fc1aa8378210c5de0655.tar.bz2
gentoo-11bbfa1b1335ea5dab99fc1aa8378210c5de0655.zip
dev-python/googleapis-common-protos: Bump to 1.55.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild')
-rw-r--r--dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild b/dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild
new file mode 100644
index 000000000000..d712f38c2e38
--- /dev/null
+++ b/dev-python/googleapis-common-protos/googleapis-common-protos-1.55.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="python classes generated from the common protos in the googleapis repository"
+HOMEPAGE="https://pypi.org/project/googleapis-common-protos/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.12.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}
+
+# no tests as this is all generated code