summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-08-16 19:42:24 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-08-16 20:00:00 -0700
commit7ca912f708c7ca6322fb03cf98a6bd396f485e28 (patch)
tree4659e6c7eeb6b87b00f9a3cbe4ec7bddc731fde7 /dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild
parentdev-python/grpcio-tools: bump to 1.22.1 (diff)
downloadgentoo-7ca912f708c7ca6322fb03cf98a6bd396f485e28.tar.gz
gentoo-7ca912f708c7ca6322fb03cf98a6bd396f485e28.tar.bz2
gentoo-7ca912f708c7ca6322fb03cf98a6bd396f485e28.zip
dev-python/grpcio-testing: bump to 1.23.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild')
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild
new file mode 100644
index 000000000000..0f6ea5237441
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.23.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"