summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-06-11 00:56:38 +0200
committerSam James <sam@gentoo.org>2021-06-21 23:30:23 +0100
commit08968a001ad84d4c6ef6e0419c063b1e93146a28 (patch)
tree6bcec1e889d49d1245cb495cb2f246f8ed26b0b1 /dev-python/gst-python/gst-python-1.18.4.ebuild
parentwww-apps/gitea: drop old (diff)
downloadgentoo-08968a001ad84d4c6ef6e0419c063b1e93146a28.tar.gz
gentoo-08968a001ad84d4c6ef6e0419c063b1e93146a28.tar.bz2
gentoo-08968a001ad84d4c6ef6e0419c063b1e93146a28.zip
dev-python/gst-python: Version bump, 1.18.4
Closes: https://bugs.gentoo.org/793191 Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/21193 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gst-python/gst-python-1.18.4.ebuild')
-rw-r--r--dev-python/gst-python/gst-python-1.18.4.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/gst-python/gst-python-1.18.4.ebuild b/dev-python/gst-python/gst-python-1.18.4.ebuild
new file mode 100644
index 000000000000..14626ea03c5e
--- /dev/null
+++ b/dev-python/gst-python/gst-python-1.18.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_8,3_9} )
+
+inherit meson python-r1 xdg-utils
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=media-libs/gstreamer-${PV}:1.0[introspection]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Avoid building & testing plugin - it must NOT be multi-python as gst-inspect will map in all libpython.so versions and crash or behave mysteriously.
+ # Python plugin support is of limited use (GIL gets in the way). If it's ever requested or needed, it should be a
+ # separate python-single-r1 media-plugins/gst-plugins-python package that only builds the plugin directory.
+ sed -e '/subdir.*plugin/d' -i meson.build || die
+ sed -e '/test_plugin.py/d' -i testsuite/meson.build || die
+
+ xdg_environment_reset
+}
+
+src_configure() {
+ configuring() {
+ meson_src_configure \
+ -Dpython="${EPYTHON}"
+ }
+ python_foreach_impl configuring
+}
+
+src_compile() {
+ python_foreach_impl meson_src_compile
+}
+
+src_test() {
+ python_foreach_impl meson_src_test
+}
+
+src_install() {
+ installing() {
+ meson_src_install
+ python_optimize
+ }
+ python_foreach_impl installing
+}