summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 16:06:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 16:06:45 +0200
commitea214408dbe713943be2d9917554c286c3780246 (patch)
tree95c22d8e1cbee60fb50527111db1f55833316a61 /dev-python/hcloud-python/hcloud-python-1.23.1.ebuild
parentdev-lang/haxe: bump to 4.3.1 (diff)
downloadgentoo-ea214408dbe713943be2d9917554c286c3780246.tar.gz
gentoo-ea214408dbe713943be2d9917554c286c3780246.tar.bz2
gentoo-ea214408dbe713943be2d9917554c286c3780246.zip
dev-python/hcloud-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hcloud-python/hcloud-python-1.23.1.ebuild')
-rw-r--r--dev-python/hcloud-python/hcloud-python-1.23.1.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild b/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild
deleted file mode 100644
index 748e02d44670..000000000000
--- a/dev-python/hcloud-python/hcloud-python-1.23.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-MY_P=hcloud-python-${PV}
-DESCRIPTION="Official Hetzner Cloud python library"
-HOMEPAGE="
- https://github.com/hetznercloud/hcloud-python/
- https://pypi.org/project/hcloud/
-"
-# sdist is missing doc assets as of 1.19.0
-# https://github.com/hetznercloud/hcloud-python/pull/183
-SRC_URI="
- https://github.com/hetznercloud/hcloud-python/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/requests-2.20[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx docs \
- dev-python/myst-parser \
- dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # Integration tests need docker:
- # https://github.com/hetznercloud/hcloud-python/blob/master/.travis.yml#L16
- tests/integration
-)
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}