summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-06-24 09:56:12 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-06-24 09:56:12 -0500
commitf86e8a03a1ebb59f5433c007b612ffe4b2747679 (patch)
tree83b16a2fe78e3f507e24e51617740b86bcd0760d /dev-python/hglib/hglib-2.1.ebuild
parentapp-misc/grabcartoons: remove git-r3 eclass, eapi bump (diff)
downloadgentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.tar.gz
gentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.tar.bz2
gentoo-f86e8a03a1ebb59f5433c007b612ffe4b2747679.zip
dev-python/hglib: version bump, drop old
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/hglib/hglib-2.1.ebuild')
-rw-r--r--dev-python/hglib/hglib-2.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/hglib/hglib-2.1.ebuild b/dev-python/hglib/hglib-2.1.ebuild
new file mode 100644
index 000000000000..671cdfc92b20
--- /dev/null
+++ b/dev-python/hglib/hglib-2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+MY_P=python-${P}
+MY_PN=python-${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Library for using the Mercurial Command Server from Python"
+HOMEPAGE="http://mercurial.selenic.com/"
+SRC_URI="mirror://pypi/p/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=dev-vcs/mercurial-2.4.2"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ if ! ${PYTHON} test.py; then
+ die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/stats.py )
+ distutils-r1_python_install_all
+}