summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/html5lib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/Manifest3
-rw-r--r--dev-python/html5lib/html5lib-0.999.ebuild27
-rw-r--r--dev-python/html5lib/html5lib-0.99999.ebuild28
-rw-r--r--dev-python/html5lib/html5lib-0.999999.ebuild28
-rw-r--r--dev-python/html5lib/metadata.xml14
5 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/html5lib/Manifest b/dev-python/html5lib/Manifest
new file mode 100644
index 000000000000..10fc08521c22
--- /dev/null
+++ b/dev-python/html5lib/Manifest
@@ -0,0 +1,3 @@
+DIST html5lib-0.999.tar.gz 885440 SHA256 c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e SHA512 12f187905510c621714c2b75c6a91cc0cbf8a790da1c715a51d08879704b55cd1c152fa236c0d8f6c8a578555103217a91a64a1af1962d02f4a656040a90bcea WHIRLPOOL 0903bbaf34fee171ef90a23e290b60b1461e071167ab624af0614b4924c0991fbb53f1a56adc1a735a5d190cc51f3ad70ce54c52e3169ebdfed73d86500f4eca
+DIST html5lib-0.99999.tar.gz 887806 SHA256 6b0bc7e9f77bb2a8ace636a827d8fb6e2f0b53e20cf0cb5e3e5b970454f8370b SHA512 ce440a03c949194a7e10cfd31557e83e60aee7899cd470e55940b5841f26ba1103ad83b96cdde7dc4eede3cf4b969bdad2c4b8530da3bc761c3ca928f149c68f WHIRLPOOL ef85ec5d2ff4edca0f66deb4ef8a1bb21ce51db33763892eefbef6bcd71000e4b3aa171434b8f2a2f0f04e21c7166d49f41acf76191acaf8fd789d5c8cc35f28
+DIST html5lib-0.999999.tar.gz 889015 SHA256 e372b66f4997f8e1de970ea755d0a528d7222d2aa9bd55aac078c7ef39b8f6c3 SHA512 ca6a5cd282099424bd770e6a38ce07d5782a3153a3d0480bc090410e8deb4f7673a1da71fb00cd097fdf7154d6f8a4f2656054666f1465d7f306233d6720d33b WHIRLPOOL 6cfe531db44ea16c07a2ed1fd8f43a44513dfb3f99b075e4ff070dab97addd1addae3b1f9cadcc116c778323e27d229f0d90f4890858d6cdd9c72106a45c8e7f
diff --git a/dev-python/html5lib/html5lib-0.999.ebuild b/dev-python/html5lib/html5lib-0.999.ebuild
new file mode 100644
index 000000000000..d350a583909f
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/html5lib-0.99999.ebuild b/dev-python/html5lib/html5lib-0.99999.ebuild
new file mode 100644
index 000000000000..897f81a24a18
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.99999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/html5lib-0.999999.ebuild b/dev-python/html5lib/html5lib-0.999999.ebuild
new file mode 100644
index 000000000000..642a13c981a9
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.999999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="https://github.com/html5lib/html5lib-python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/html5lib/metadata.xml b/dev-python/html5lib/metadata.xml
new file mode 100644
index 000000000000..ab82d54bc79f
--- /dev/null
+++ b/dev-python/html5lib/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ html5lib is a pure-python library for parsing HTML. It is designed
+ to conform to the WHATWG HTML specification, as is implemented by
+ all major web browsers.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">html5lib</remote-id>
+ <remote-id type="github">html5lib/html5lib-python</remote-id>
+ </upstream>
+</pkgmetadata>