summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 22:24:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 22:31:11 +0100
commit6f73dd499827f3ee53c0403d54eaa105682c1097 (patch)
tree0e50b77c9e551a62b7b72ab4bdf196938583ebed /dev-python/hyperlink
parentdev-python/hyperlink: Add pypy3 love (diff)
downloadgentoo-6f73dd499827f3ee53c0403d54eaa105682c1097.tar.gz
gentoo-6f73dd499827f3ee53c0403d54eaa105682c1097.tar.bz2
gentoo-6f73dd499827f3ee53c0403d54eaa105682c1097.zip
dev-python/hyperlink: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
new file mode 100644
index 000000000000..9ed1cd2d977c
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-21.0.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # suppresses hypothesis health checks
+ local -x CI=1
+ epytest
+}