summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-15 04:05:38 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-15 04:05:38 +0100
commit1a8226f075a8fc51728fbec61c5db1545b78e75f (patch)
treeead3454e671952647b17c6ee22cb3314065b8615 /dev-python/hypothesis
parentapp-admin/awscli: Bump to 1.32.42 (diff)
downloadgentoo-1a8226f075a8fc51728fbec61c5db1545b78e75f.tar.gz
gentoo-1a8226f075a8fc51728fbec61c5db1545b78e75f.tar.bz2
gentoo-1a8226f075a8fc51728fbec61c5db1545b78e75f.zip
dev-python/hypothesis: Bump to 6.98.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.98.5.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 8fa3eeba51e7..e6b74c2ccf1f 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -8,3 +8,4 @@ DIST hypothesis-6.98.1.gh.tar.gz 9438665 BLAKE2B c2529e19b8ac039db334a51b33e0552
DIST hypothesis-6.98.2.gh.tar.gz 9438703 BLAKE2B e1c93ae8f428c95e5bf9d6d6364717378f12ad829b7754f8793b19342adc24c5c90f2e8975469b568378768c9e8a0dd39051b5cf8b1616a119c1531261f4f60c SHA512 81a6b919107a35825af15c2dea91c0010611bd0756172aae76be195b5751a58542a28eb8cecd02f79d43287d013b1dbadad6991ef3057adfddad95a1a7447a92
DIST hypothesis-6.98.3.gh.tar.gz 9438865 BLAKE2B 7a15ec4debd2a93974aca75aad9b7b1858c6ec23dc4856ef2b4a84e9eb6e74a0aabd278070cd76b83c12e71144e0b613c33d00ab87d9b2dc85d713c7be7f56c6 SHA512 6ad4dfaa8ed54c090b3fcd2c8ee742ebf7f488dd156dcec4ee138621ee16143f520f660d6081fbe05d8f59f7dbef2b575128806a71ff7f793fc7b2d61bf9dc78
DIST hypothesis-6.98.4.gh.tar.gz 9438902 BLAKE2B a5c560711448c301665a9c9d2f6106996fbf76d1fc3c3e8d67e053c94a59f462cb57ddb890b1dfb0bdd3569e1e6216d5fd4bcab10adf0ba0499caf84efeb3b25 SHA512 3f4496f48b3002f33a9324509463a4fbece7967f203a9b4a7e1a5bce557e296d0b335437fa590477e8e669b551618cd83fad2bc2478c443772399467f17988f7
+DIST hypothesis-6.98.5.gh.tar.gz 9422518 BLAKE2B ff79d5ddad7d1474ccc536dba4222e8ba19a5066011e532384a7b1e686b44a2e4bd48df107b6be868e40513ee691dc3d8d401ac22109f058a948c0eec1d5266a SHA512 c77714986451eb9992254734b5302979ea51e5baae769e57a1076dd770abfe7c61ce38be865552d4961d5a6f2ae3d7325888404265e92a106f2c2cdc177f624d
diff --git a/dev-python/hypothesis/hypothesis-6.98.5.ebuild b/dev-python/hypothesis/hypothesis-6.98.5.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.98.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}