summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-15 23:18:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-16 00:19:15 +0200
commitce0dd8148039f27e10eb0f353f114433c54ba65c (patch)
tree4adefabe0d338962f0f5272073fafd1fae60e408 /dev-python/hypothesis
parentdev-python/feedparser: Bump to 6.0.1 (diff)
downloadgentoo-ce0dd8148039f27e10eb0f353f114433c54ba65c.tar.gz
gentoo-ce0dd8148039f27e10eb0f353f114433c54ba65c.tar.bz2
gentoo-ce0dd8148039f27e10eb0f353f114433c54ba65c.zip
dev-python/hypothesis: Bump to 5.35.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.35.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 332328ad8daa..8bc98bd01ab7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-5.24.4.tar.gz 9054743 BLAKE2B 5c64c86ed58d8f0e4a07390b1b1
DIST hypothesis-python-5.29.4.tar.gz 9071060 BLAKE2B 0668f3c7859fae7024c15f693b1f56ce8d02d6f3b8187d24b2d84e38e7bdb73c0824d2b02cfecc6b40bdfbbb1c91c0aa83d40848c499a97ab7e9223aaa6c78d4 SHA512 9da4b487fd3c56540a20e2fbff635704f0720f422d8a398d0accd24a1fb9517476b0d29135b9113a96e8dc98fcfc31cc53215ad82cb727be54e4e77b44d4c8e4
DIST hypothesis-python-5.35.0.tar.gz 9081292 BLAKE2B 8f1d50d76f589103f7b734cea6008b3533d3c0d62f45ab95a71f079833cb20b766d398a1b9492d592a93156d097d58c14041caf609f035b547f2234cbef2d602 SHA512 e99ce4c2801341fc43c4290afb551bcae69e0747a6b98a633b284bce009cc18d978b75a23bf22dafb39c5020595159806d5627128577770be3aad72a022549a3
DIST hypothesis-python-5.35.2.tar.gz 9082095 BLAKE2B 6d2d2f74519975455a6d73f5d006837f7f71d162c5fe84c33afe81c7a110ecd93d2643db5b1ed8b00aec212c5c311254dcfbd66ae5bd08b077335a3754c9e9b4 SHA512 f17b7783d689986703bc6755a7dc30e8bfd4977a128954481067780d14b1b3f4bbfb21751a607a215357b5d300ad4e06ce951b81059ac8638c84005d682e2398
+DIST hypothesis-python-5.35.3.tar.gz 9084707 BLAKE2B ff0638194067a1c52a0297254be572ba66d67afa49c1f2fbcc42bff694ab4fe545d408d9144118314a6decfdffdbe950e2b72e89b689ae99b82ad3d3321e72fd SHA512 d862cba17444b36fa05877419495b5e49e8686980e0203da388e2dc4e528ace928f0bcb244afc8512f97bf466f2e5a2a421a2c873053849af61de71421d5c61a
diff --git a/dev-python/hypothesis/hypothesis-5.35.3.ebuild b/dev-python/hypothesis/hypothesis-5.35.3.ebuild
new file mode 100644
index 000000000000..c8d53477c0bc
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.35.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}