summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 14:27:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:12:11 +0100
commit8aa40a85108f704a9a291c14410e127d59379eed (patch)
tree3c4fb2d282194d215a40fe2d1da65bd9071e10e1 /dev-python/identify
parentdev-python/pyproject-api: Bump to 1.3.0 (diff)
downloadgentoo-8aa40a85108f704a9a291c14410e127d59379eed.tar.gz
gentoo-8aa40a85108f704a9a291c14410e127d59379eed.tar.bz2
gentoo-8aa40a85108f704a9a291c14410e127d59379eed.zip
dev-python/identify: Bump to 2.5.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.12.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 444988971781..2400d96e890d 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.5.11.gh.tar.gz 101504 BLAKE2B 0415e9ab67c4254f3dd096364f518b131568c2180b8fdc5096405bae11854d5ef953eae01ad13292b6948d76f02adeee4607cd9485b705b1a303c44bc7110409 SHA512 cba8df5abacfc4db4305501eb6566ef3c9b3e0557796c046159f60a88ee3d0e206e13b070a01c3f7da74f8abf7a17e1374c40dc61814b5b580d1f8508034c402
+DIST identify-2.5.12.gh.tar.gz 101331 BLAKE2B 5335d8e4628921ca813c37197adc8802dc64adec021c80a3babfe2a8f9d27d96c00ae6dcfb0b3aaa6c4ffbde4c74fca6113e94abe7a79122605475c0f9f697d8 SHA512 6b2e9818bdce4c8944fed380708edac0f46f5ff481dfe19358aaf19996af5c9631bd1d68c399bef04768e924423a02519bcd28c58b0f83d455151f90afe4b2a6
diff --git a/dev-python/identify/identify-2.5.12.ebuild b/dev-python/identify/identify-2.5.12.ebuild
new file mode 100644
index 000000000000..af4367ae7741
--- /dev/null
+++ b/dev-python/identify/identify-2.5.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest