summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-07-30 16:29:08 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-07-30 16:29:24 -0700
commit1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3 (patch)
treeba67edf2b9b2ecad2302ce95d7b51cd3f32e3d16 /dev-python/ijson/ijson-3.1_p0.ebuild
parentdev-python/more-itertools: ALLARCHES stable (via arm, bug #734436) (diff)
downloadgentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.tar.gz
gentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.tar.bz2
gentoo-1a3f6b58f1b9b5b1e49251d9ad989e93c3ec02d3.zip
dev-python/ijson-3.1_p0: version bump, add py3{8,9}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ijson/ijson-3.1_p0.ebuild')
-rw-r--r--dev-python/ijson/ijson-3.1_p0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ijson/ijson-3.1_p0.ebuild b/dev-python/ijson/ijson-3.1_p0.ebuild
new file mode 100644
index 000000000000..a8112d927075
--- /dev/null
+++ b/dev-python/ijson/ijson-3.1_p0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson
+ https://pypi.org/project/ijson/
+"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/yajl
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest