summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-12 20:10:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-12 20:27:59 +0200
commit5d76ac34ce7fc51205f8cd1387796ad1d7b81c34 (patch)
tree65108c345282bc35fe7aba666154222bb6f0df4e /dev-python/imageio-ffmpeg
parentdev-python/iniparse: Enable py3.11 (diff)
downloadgentoo-5d76ac34ce7fc51205f8cd1387796ad1d7b81c34.tar.gz
gentoo-5d76ac34ce7fc51205f8cd1387796ad1d7b81c34.tar.bz2
gentoo-5d76ac34ce7fc51205f8cd1387796ad1d7b81c34.zip
dev-python/imageio-ffmpeg: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio-ffmpeg')
-rw-r--r--dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.7.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.7.ebuild b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.7.ebuild
index 1ec434ff4fe6..f560bc2f9a3c 100644
--- a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.7.ebuild
+++ b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.7.ebuild
@@ -4,11 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="FFMPEG wrapper for Python"
-HOMEPAGE="https://pypi.org/project/imageio-ffmpeg/ https://github.com/imageio/imageio-ffmpeg"
+HOMEPAGE="
+ https://github.com/imageio/imageio-ffmpeg/
+ https://pypi.org/project/imageio-ffmpeg/
+"
SRC_URI="
https://github.com/imageio/imageio-ffmpeg/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -20,8 +24,10 @@ KEYWORDS="~amd64 ~x86"
PROPERTIES="test_network"
RESTRICT="test"
-# ffmpeg is used as executable during runtime
-RDEPEND="media-video/ffmpeg:*"
+# ffmpeg is used as an executable during runtime
+RDEPEND="
+ media-video/ffmpeg:*
+"
distutils_enable_tests pytest