summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2020-08-22 11:14:17 -0700
committerSam James <sam@gentoo.org>2020-09-16 01:14:51 +0000
commit969c2603e839604996ecf28d7996431d0f0a13f9 (patch)
tree4c8bd3513168a0067ea20b73c9f2d3f5a89ceb92 /dev-python/influxdb/influxdb-5.3.0-r1.ebuild
parentdev-python/PyQtWebEngine: add 5.15.1 (diff)
downloadgentoo-969c2603e839604996ecf28d7996431d0f0a13f9.tar.gz
gentoo-969c2603e839604996ecf28d7996431d0f0a13f9.tar.bz2
gentoo-969c2603e839604996ecf28d7996431d0f0a13f9.zip
dev-python/influxdb: revbump, fix test, Py3.8
Add a patch that fixes a FutureWarning in the test suite. Add Python 3.8 to the list of supported interpreters; it passes the test suite. Closes: https://bugs.gentoo.org/737976 Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/17215 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/influxdb/influxdb-5.3.0-r1.ebuild')
-rw-r--r--dev-python/influxdb/influxdb-5.3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/influxdb/influxdb-5.3.0-r1.ebuild b/dev-python/influxdb/influxdb-5.3.0-r1.ebuild
new file mode 100644
index 000000000000..178929abf867
--- /dev/null
+++ b/dev-python/influxdb/influxdb-5.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="InfluxDB client"
+HOMEPAGE="https://github.com/influxdb/influxdb-python https://pypi.org/project/influxdb/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/msgpack-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.17.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="test? (
+ dev-db/influxdb
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-pandas-future-warning.patch" )
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # The tarball is missing this file.
+ # <https://github.com/influxdata/influxdb-python/issues/714>
+ cp "${FILESDIR}/influxdb.conf.template" "${S}/influxdb/tests/server_tests/influxdb.conf.template" || die
+ default
+}