summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:22:30 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit02365548150d6f068ef7d5c56143476e4aea9328 (patch)
tree659ae9d73a367fd4cf34ef5c3e46ba8c1fe8ce08 /dev-python/ipaddress
parentdev-python/idna: Add python3.5 support (diff)
downloadgentoo-02365548150d6f068ef7d5c56143476e4aea9328.tar.gz
gentoo-02365548150d6f068ef7d5c56143476e4aea9328.tar.bz2
gentoo-02365548150d6f068ef7d5c56143476e4aea9328.zip
dev-python/ipaddress: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ipaddress')
-rw-r--r--dev-python/ipaddress/ipaddress-1.0.14-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ipaddress/ipaddress-1.0.14-r1.ebuild b/dev-python/ipaddress/ipaddress-1.0.14-r1.ebuild
new file mode 100644
index 000000000000..74fbeef0c74f
--- /dev/null
+++ b/dev-python/ipaddress/ipaddress-1.0.14-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="IPv4/IPv6 manipulation library, a port of the ipaddress module"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test_ipaddress.py || die
+}