summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-12 18:53:26 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-12 19:38:23 +0100
commit43a8e0b5113d975f884f2c808e662397b17217da (patch)
treeaf7a444722da12a23ecd198fe1210f04827e12e5 /dev-python/ipaddress
parentvirtual/python-ipaddress: Add new virtual for module with mixed impl support (diff)
downloadgentoo-43a8e0b5113d975f884f2c808e662397b17217da.tar.gz
gentoo-43a8e0b5113d975f884f2c808e662397b17217da.tar.bz2
gentoo-43a8e0b5113d975f884f2c808e662397b17217da.zip
dev-python/ipaddress: Version Bump and impl cleanup
As this is a backport, packages should use the standard libraries and depend on the virtual Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ipaddress')
-rw-r--r--dev-python/ipaddress/Manifest1
-rw-r--r--dev-python/ipaddress/ipaddress-1.0.14.ebuild4
-rw-r--r--dev-python/ipaddress/ipaddress-1.0.15.ebuild25
3 files changed, 28 insertions, 2 deletions
diff --git a/dev-python/ipaddress/Manifest b/dev-python/ipaddress/Manifest
index 8a5c56ad5bb4..afa1b8a4df34 100644
--- a/dev-python/ipaddress/Manifest
+++ b/dev-python/ipaddress/Manifest
@@ -1 +1,2 @@
DIST ipaddress-1.0.14.tar.gz 30429 SHA256 226f4be44c6cb64055e23060848266f51f329813baae28b53dc50e93488b3b3e SHA512 fb33b484ca435f4e8817c735a1084f2fa749abca4643a10be644003fdb73cc9205fc28f484ef96d2db90e8b27d8a238d1d7cf20140f7942e39be12c7524e8d6f WHIRLPOOL 30e21d5b7568125575fecd0f8cac4172713c029faa81f88cd2a6111b47da1fb3bea9305a9311ce1a7b2795e9d54b58f2cbef1e5b66f355b8c91633ead0836d04
+DIST ipaddress-1.0.15.tar.gz 30438 SHA256 af6c85cfc9cdb12b861655e6b9f2f59618bf3088cbde858727b2c0a98e9f6636 SHA512 6cb53a2689da356b9f853bca564ca41b9d9c5700dd3c46c6f2937f2f7f97f955f3e351700494fdd2f20d6333f5feb2e5cb2d957eb4c626cc2c28cc3521fca0a1 WHIRLPOOL e1dd179078cddb62232468e8ea6032272c41892c23d6a77269ddb4daf70d9eb5a3a1a908e8e4d2c077a2959a79665e65b9c1b0a9f4f698217c9b87a7480da0a7
diff --git a/dev-python/ipaddress/ipaddress-1.0.14.ebuild b/dev-python/ipaddress/ipaddress-1.0.14.ebuild
index 5d183f5a5b9e..66167cf6f6b2 100644
--- a/dev-python/ipaddress/ipaddress-1.0.14.ebuild
+++ b/dev-python/ipaddress/ipaddress-1.0.14.ebuild
@@ -4,11 +4,11 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
inherit distutils-r1
-DESCRIPTION="IPv4/IPv6 manipulation library, a port of the ipaddress module"
+DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
HOMEPAGE="https://github.com/phihag/ipaddress"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
diff --git a/dev-python/ipaddress/ipaddress-1.0.15.ebuild b/dev-python/ipaddress/ipaddress-1.0.15.ebuild
new file mode 100644
index 000000000000..182e7d2543d5
--- /dev/null
+++ b/dev-python/ipaddress/ipaddress-1.0.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" test_ipaddress.py || die
+}