summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:30:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:30:04 +0300
commit4f28260880a4b4cb0a30add648b97a8951d788c1 (patch)
tree2f06445e643de999c787259d8716c4b542a9c678 /dev-python/jaraco-collections
parentdev-python/jaraco-context: add 4.1.2 (diff)
downloadgentoo-4f28260880a4b4cb0a30add648b97a8951d788c1.tar.gz
gentoo-4f28260880a4b4cb0a30add648b97a8951d788c1.tar.bz2
gentoo-4f28260880a4b4cb0a30add648b97a8951d788c1.zip
dev-python/jaraco-collections: add 3.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index f9f4233ae2a1..303fcfa65b28 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1 +1,2 @@
DIST jaraco.collections-3.5.1.tar.gz 15053 BLAKE2B afba813636464b6776f244eab31a0cd86418410f313e171cff1c8ac64e5d902f4a6c2f88d87c61d55292baa338aee45866d3a459c5b5b73fd4e751278b869316 SHA512 2918be537296ca81e5f78a3966a47451dc9dc2d233d997c3f01461c489b44051c497dab55496f85883ac1b91a28850a9d77ff154a3f5e074da1ed07f3259c246
+DIST jaraco.collections-3.5.2.tar.gz 16038 BLAKE2B 3f7f48f4c65e44aba621dd894a84711473ff42e37be8067e356cd6ca0f8740c667cb282bddad4315ddd7c8922c316c57b40984455f0af4bc8bbf4304a12a6779 SHA512 9567ee44fbc5010cc81ee24de792e53b5a225759b5f7d2e7dd932b0cae38e2035fddb5bd3dee5dc08fea9c61e2bf9087418cd192d81c72760f1e0d95a7b3788c
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
new file mode 100644
index 000000000000..2d4ec2a0c605
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-3.5.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9'
+distutils_enable_tests pytest