summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jedi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jedi')
-rw-r--r--dev-python/jedi/Manifest2
-rw-r--r--dev-python/jedi/jedi-0.8.1-r2.ebuild43
-rw-r--r--dev-python/jedi/jedi-0.9.0.ebuild40
-rw-r--r--dev-python/jedi/metadata.xml9
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/jedi/Manifest b/dev-python/jedi/Manifest
new file mode 100644
index 000000000000..f0778650d9b0
--- /dev/null
+++ b/dev-python/jedi/Manifest
@@ -0,0 +1,2 @@
+DIST jedi-0.8.1.tar.gz 304088 SHA256 4d23ae457cec14cedb71fb56f0ed51d75798f2fd74e91f6e5134b09a4a78eba8 SHA512 2188bf0eede9d78a298c0cd6071060e74b0531ebd3c21d4e831c77202b7e338452f0ab10b693902e5b0da8095f394e5c67e055f1cde3a476fc2566b627bb6d9f WHIRLPOOL ecc131bd7a9ee046200ebe089cb37b7afe6b9bfd9522329b96418f34383fbf7f60957cba8deb9799bff804783c7b5a909159717f382da9d979d13c57c8f92066
+DIST jedi-0.9.0.tar.gz 334204 SHA256 3b4c19fba31bdead9ab7350fb9fa7c914c59b0a807dcdd5c00a05feb85491d31 SHA512 fa60861bde0afb63c90b0e14b252d33b68d5e83255d662ef727884c91bd530b5a76f0306965ed9620d7d42a92f177feb2524a7b088ade786fb486d62d6912e57 WHIRLPOOL a6233ed19129f129cd97778f1c01bdc1e0747ec1da3611164c50815c77ab57ca1c8d7bec824b00d105cac62d32f53981a54e72b80ddfef00a77cd9316aef94aa
diff --git a/dev-python/jedi/jedi-0.8.1-r2.ebuild b/dev-python/jedi/jedi-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..47c34d6699e8
--- /dev/null
+++ b/dev-python/jedi/jedi-0.8.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Awesome autocompletion library for python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+DEPEND="
+ app-arch/xz-utils
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || die "Tests failed under ${EPYTHON}"
+}
+
+src_compile() {
+ if use doc ; then
+ emake -C docs html
+ fi
+ distutils-r1_src_compile
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}"/docs/_build/html/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jedi/jedi-0.9.0.ebuild b/dev-python/jedi/jedi-0.9.0.ebuild
new file mode 100644
index 000000000000..0c0b29a0f32f
--- /dev/null
+++ b/dev-python/jedi/jedi-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Awesome autocompletion library for python"
+HOMEPAGE="https://github.com/davidhalter/jedi"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ app-arch/xz-utils
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ PYTHONPATH="${PYTHONPATH%:}${PYTHONPATH+:}${S}/test" py.test test || die "Tests failed under ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}"/docs/_build/html/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jedi/metadata.xml b/dev-python/jedi/metadata.xml
new file mode 100644
index 000000000000..8fd43766e8bd
--- /dev/null
+++ b/dev-python/jedi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">jedi</remote-id>
+ <remote-id type="github">davidhalter/jedi</remote-id>
+ </upstream>
+</pkgmetadata>