summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-09-04 00:29:08 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-09-05 15:30:10 +0200
commit7e73ae48bc3c28b105a5f4b7a720c12e5598da2b (patch)
treed896ca682cc65ce972ef0285b07b3c16412a75f3 /dev-python/jeepney/jeepney-0.3.1.ebuild
parentdev-vcs/git: Bump to version 2.19.0_rc2. Removed old. (diff)
downloadgentoo-7e73ae48bc3c28b105a5f4b7a720c12e5598da2b.tar.gz
gentoo-7e73ae48bc3c28b105a5f4b7a720c12e5598da2b.tar.bz2
gentoo-7e73ae48bc3c28b105a5f4b7a720c12e5598da2b.zip
dev-python/jeepney: new pkg, required by dev-python/secretstorage
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-python/jeepney/jeepney-0.3.1.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.3.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jeepney/jeepney-0.3.1.ebuild b/dev-python/jeepney/jeepney-0.3.1.ebuild
new file mode 100644
index 000000000000..0f8244e39400
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python 3.4 and older aren't supported
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}