summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-02-24 10:02:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-02-24 10:30:55 +0200
commit966d037229026a0bbf44f1183fe66dde4e647aa6 (patch)
tree144dfef09688d8e2617d1035b6dd73e5363cce02 /dev-python/js2py
parentdev-python/pyjsparser: new package; add 2.7.1_p20190421 (diff)
downloadgentoo-966d037229026a0bbf44f1183fe66dde4e647aa6.tar.gz
gentoo-966d037229026a0bbf44f1183fe66dde4e647aa6.tar.bz2
gentoo-966d037229026a0bbf44f1183fe66dde4e647aa6.zip
dev-python/js2py: open the if statement, use double brackets
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/js2py')
-rw-r--r--dev-python/js2py/js2py-0.70_p20210218.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/js2py/js2py-0.70_p20210218.ebuild b/dev-python/js2py/js2py-0.70_p20210218.ebuild
index 89897bdcda22..998dd3f8363e 100644
--- a/dev-python/js2py/js2py-0.70_p20210218.ebuild
+++ b/dev-python/js2py/js2py-0.70_p20210218.ebuild
@@ -36,9 +36,11 @@ python_test() {
pushd ./tests >/dev/null || die
# Tests require "node_failed.txt" file where the logs are kept
- [ -f ./node_failed.txt ] && rm ./node_failed.txt
- touch ./node_failed.txt || die
+ if [[ -f ./node_failed.txt ]]; then
+ rm ./node_failed.txt || die
+ fi
+ touch ./node_failed.txt || die
"${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
popd >/dev/null || die