summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 07:37:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:40:12 +0200
commitfe73875143cab229fc5e8621a351482fd9954e8a (patch)
tree5e9b37d25fdbbd36e91d5c2b1c89242a2811711f /dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
parentdev-python/apipkg: Remove old (diff)
downloadgentoo-fe73875143cab229fc5e8621a351482fd9954e8a.tar.gz
gentoo-fe73875143cab229fc5e8621a351482fd9954e8a.tar.bz2
gentoo-fe73875143cab229fc5e8621a351482fd9954e8a.zip
dev-python/jschema-to-python: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild')
-rw-r--r--dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild b/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
index 08cc0d5a6fae..d123bb88d2c1 100644
--- a/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
+++ b/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
@@ -3,14 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1 pypi
DESCRIPTION="Generate source code for Python classes from a JSON schema"
HOMEPAGE="
https://pypi.org/project/jschema-to-python/
- https://github.com/microsoft/jschema-to-python/"
+ https://github.com/microsoft/jschema-to-python/
+"
LICENSE="MIT"
SLOT="0"
@@ -19,8 +21,10 @@ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]
dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]"
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
BDEPEND="
- dev-python/pbr[${PYTHON_USEDEP}]"
+ dev-python/pbr[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest