summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-13 09:26:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-13 12:32:08 +0200
commit29fb27bc66f859b2ec4d1c5ad13ce99c1cb14f70 (patch)
treea01b8c70f2b9ca76df2640002dfdc4cd020e1d88 /dev-python/jsonrpclib
parentdev-python/hypothesis: Bump to 5.8.3 (diff)
downloadgentoo-29fb27bc66f859b2ec4d1c5ad13ce99c1cb14f70.tar.gz
gentoo-29fb27bc66f859b2ec4d1c5ad13ce99c1cb14f70.tar.bz2
gentoo-29fb27bc66f859b2ec4d1c5ad13ce99c1cb14f70.zip
dev-python/jsonrpclib: Bump to 0.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest1
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
index 76beded141e4..2fa0d2a8b58e 100644
--- a/dev-python/jsonrpclib/Manifest
+++ b/dev-python/jsonrpclib/Manifest
@@ -1 +1,2 @@
DIST jsonrpclib-0.4.0.tar.gz 57944 BLAKE2B 3458aee2dc27980ef93d7ae650f7d7485983598c8276f08b104a5b44d5dfb8f6225ba649dc7f6537fa66f6ba86d7082e11e23c7ca051c876a96d1b25efa4fa0e SHA512 357743e34447cd6dbe330c5adfa5541134a0ff8d82549ec47ed741ddf54a7aabb8cd417c501cb9ab814ce2cb90e1c2d4d4f21daac3b379f38be03c38a7ed198b
+DIST jsonrpclib-0.4.1.tar.gz 58293 BLAKE2B 29beafb412402549d625efb2cbd00d75d70a9582a48eb9223d9b8f8778bf186a80936dfb35ad47186634aab862311e048d556958a4133d0f8461163a51ead4e2 SHA512 9e0c06c016a9e117bb0b8e0fa1dd9e472ef2e280ef5efee51d491f339c8792477430390918fc46a2d8bfbbbe4baa9d4289f67775b879d2a49a35fc7bd1e8ecaa
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild
new file mode 100644
index 000000000000..3caeeb9a0089
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}