summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-16 17:53:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-16 18:21:35 +0100
commit20c21d4198aa6b7b21467ebbc022e14b971ab6dd (patch)
treefa834c85be0e9f44ad4b474ddf8ac7b52880e6f3 /dev-python/jupyter_client/jupyter_client-7.4.7.ebuild
parentapp-eselect/eselect-wine: switch upstream metadata to gentoo (diff)
downloadgentoo-20c21d4198aa6b7b21467ebbc022e14b971ab6dd.tar.gz
gentoo-20c21d4198aa6b7b21467ebbc022e14b971ab6dd.tar.bz2
gentoo-20c21d4198aa6b7b21467ebbc022e14b971ab6dd.zip
dev-python/jupyter_client: Bump to 7.4.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-7.4.7.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.4.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-7.4.7.ebuild b/dev-python/jupyter_client/jupyter_client-7.4.7.ebuild
new file mode 100644
index 000000000000..36545e34222b
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-7.4.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/entrypoints[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.9.2[${PYTHON_USEDEP}]
+ >=dev-python/nest_asyncio-1.5.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.12[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
+)
+
+distutils_enable_tests pytest