summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:06:41 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:06:41 +0100
commitc354eaf7da2acf618bd535dcf705e22d5d559c0e (patch)
tree26e1a32da8741293ac0ffcedcedb018e4aae9d16 /dev-python/jupyter_core
parentdev-python/traitlets: Import from science overlay (diff)
downloadgentoo-c354eaf7da2acf618bd535dcf705e22d5d559c0e.tar.gz
gentoo-c354eaf7da2acf618bd535dcf705e22d5d559c0e.tar.bz2
gentoo-c354eaf7da2acf618bd535dcf705e22d5d559c0e.zip
dev-python/jupyter_core: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.0.6.ebuild54
-rw-r--r--dev-python/jupyter_core/metadata.xml14
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
new file mode 100644
index 000000000000..e12c074e7c3b
--- /dev/null
+++ b/dev-python/jupyter_core/Manifest
@@ -0,0 +1 @@
+DIST jupyter_core-4.0.6.tar.gz 55060 SHA256 96a68a3b1d018ff7776270b26b7cb0cfd7a18a53ef2061421daff435707d198c SHA512 e6d7a0293ce6cdd3202b354aae62900683eb0474590980bf3d9c6f89b4b16182e7caee0e42c3feb3de5851535a01394b20725d9428eb105dbc2c34d90e0d398b WHIRLPOOL c1370d386c63665db1a47f1df0e3942c713b4f9e71ad5a2bd8c83bcf1b5dfe937fdadcd606335a989514499b9e6446d92a0bb250b9e972181b12d0d9423ee80a
diff --git a/dev-python/jupyter_core/jupyter_core-4.0.6.ebuild b/dev-python/jupyter_core/jupyter_core-4.0.6.ebuild
new file mode 100644
index 000000000000..97392a8a5a4d
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ distutils_install_for_testing
+ cd "${TEST_DIR}"/lib || die
+ py.test jupyter_core || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jupyter_core/metadata.xml b/dev-python/jupyter_core/metadata.xml
new file mode 100644
index 000000000000..07c5e187e973
--- /dev/null
+++ b/dev-python/jupyter_core/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ Core common functionality of Jupyter projects.
+ This package contains base application classes and configuration
+ inhertited by other projects. It doesn't do much on its own.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jupyter_core</remote-id>
+ <remote-id type="github">jupyter/jupyter_core</remote-id>
+ </upstream>
+</pkgmetadata>