summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-07 09:01:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-07 10:26:29 +0100
commit7b9e47bef58a3caa33a905ee03a63572cbfe3c81 (patch)
tree317c801f0a673e96c966599b0cdeb4af74803bba /dev-python/keyring/keyring-23.13.1-r1.ebuild
parentpypi.eclass: Permit EAPI 7 (diff)
downloadgentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.tar.gz
gentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.tar.bz2
gentoo-7b9e47bef58a3caa33a905ee03a63572cbfe3c81.zip
dev-python/keyring: Switch to using PyPI sdist
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring/keyring-23.13.1-r1.ebuild')
-rw-r--r--dev-python/keyring/keyring-23.13.1-r1.ebuild15
1 files changed, 1 insertions, 14 deletions
diff --git a/dev-python/keyring/keyring-23.13.1-r1.ebuild b/dev-python/keyring/keyring-23.13.1-r1.ebuild
index fcef2b34ff55..31b420a665bd 100644
--- a/dev-python/keyring/keyring-23.13.1-r1.ebuild
+++ b/dev-python/keyring/keyring-23.13.1-r1.ebuild
@@ -6,17 +6,13 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} pypy3 )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Provides access to the system keyring service"
HOMEPAGE="
https://github.com/jaraco/keyring/
https://pypi.org/project/keyring/
"
-SRC_URI="
- https://github.com/jaraco/keyring/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
SLOT="0"
LICENSE="PSF-2"
@@ -39,8 +35,6 @@ BDEPEND="
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
EPYTEST_DESELECT=(
# this test fails if importlib-metadata returns more than one
# entry, i.e. when keyring is installed already
@@ -53,10 +47,3 @@ EPYTEST_IGNORE=(
# hangs
tests/backends/test_kwallet.py
)
-
-python_compile() {
- distutils-r1_python_compile
- # https://github.com/jaraco/keyring/issues/621
- python_moduleinto keyring
- python_domodule keyring/{py.typed,*.zsh}
-}