summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-08-29 21:42:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-08-29 21:53:32 +0300
commitbc01500ac948b0116bf4c7b3b1e61f25cb0cd588 (patch)
treea3e1d3902f523206c46e65f535a3343be7f93a2b /dev-python/keystoneauth1
parentdev-python/zeroconf: add 0.88.0 (diff)
downloadgentoo-bc01500ac948b0116bf4c7b3b1e61f25cb0cd588.tar.gz
gentoo-bc01500ac948b0116bf4c7b3b1e61f25cb0cd588.tar.bz2
gentoo-bc01500ac948b0116bf4c7b3b1e61f25cb0cd588.zip
dev-python/keystoneauth1: add 5.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth1')
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.3.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index 02e084872252..dd80febc7c5b 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.2.1.tar.gz 273214 BLAKE2B 1edeaf982dbdf9c4c0d3ba15762a37104bd355bc5de848d05bbc1d51b914875f8ff47be3777f57e03b10a0ad837f29c1ad8df8666a4839a51688afd6894706be SHA512 912833a84cc47e13db851cfd34e6d4e74d3f3594f15c5e5a94c318d7a720145cc226a85921a7aed6e1385b4b260fc3f966a1d558d5165af3bc39ed87e2a148ba
+DIST keystoneauth1-5.3.0.tar.gz 274216 BLAKE2B 873a0bde2507b4b4b2bfc748d77b1c0b8be321c51cff0376020e84a63cebd030b118c90765302ce8cd51467f5c615a9b289480a1105f4d7a4a86e96fe44f7089 SHA512 91a9f9359926932a2e78a9164f8a1f2d08da306cc83f011f9a19535795b6a7faa3af0673665444532893325a2fe752f1d6a18e04b84ea1b3db8c9d1647b4f3cb
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.3.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.3.0.ebuild
new file mode 100644
index 000000000000..b0f8223e4c1a
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}