summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-07 09:20:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-07 09:20:22 +0200
commit8e4a7bc43df918879d9297ac13d1aea0c7c9e1ce (patch)
tree53dd6fcb40be817e67d6badd06db9d19c64dd9b9 /dev-python/kgb/kgb-7.1.1.ebuild
parentsys-kernel/pf-sources: drop 5.18_p3, 5.18_p4 (diff)
downloadgentoo-8e4a7bc43df918879d9297ac13d1aea0c7c9e1ce.tar.gz
gentoo-8e4a7bc43df918879d9297ac13d1aea0c7c9e1ce.tar.bz2
gentoo-8e4a7bc43df918879d9297ac13d1aea0c7c9e1ce.zip
dev-python/kgb: Bump to 7.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kgb/kgb-7.1.1.ebuild')
-rw-r--r--dev-python/kgb/kgb-7.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/kgb/kgb-7.1.1.ebuild b/dev-python/kgb/kgb-7.1.1.ebuild
new file mode 100644
index 000000000000..c7f92d10cca2
--- /dev/null
+++ b/dev-python/kgb/kgb-7.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${PN}-release-${PV}
+DESCRIPTION="Python function spy support for unit tests"
+HOMEPAGE="
+ https://github.com/beanbaginc/kgb/
+ https://pypi.org/project/kgb/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove .dev tag that breaks revdeps
+ sed -i -e '/tag_build/d' setup.cfg || die
+ distutils-r1_src_prepare
+}