summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/logilab-common/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/logilab-common/files')
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch13
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.60.0-skip-doctest.patch13
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch b/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch
new file mode 100644
index 000000000000..6807c5544c83
--- /dev/null
+++ b/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch
@@ -0,0 +1,13 @@
+Make sure setuptools does not create a zip file in python_test; this is buggy
+and causes tests to fail.
+
+--- a/setup.py
++++ b/setup.py
+@@ -179,6 +179,7 @@
+ ext_modules = ext_modules,
+ cmdclass = {'install_lib': MyInstallLib,
+ 'build_py': MyBuildPy},
++ zip_safe = False,
+ **kwargs
+ )
+
diff --git a/dev-python/logilab-common/files/logilab-common-0.60.0-skip-doctest.patch b/dev-python/logilab-common/files/logilab-common-0.60.0-skip-doctest.patch
new file mode 100644
index 000000000000..019ce619ac6a
--- /dev/null
+++ b/dev-python/logilab-common/files/logilab-common-0.60.0-skip-doctest.patch
@@ -0,0 +1,13 @@
+http://www.logilab.org/ticket/174440
+diff --git a/textutils.py b/textutils.py
+--- a/textutils.py
++++ b/textutils.py
+@@ -287,7 +287,7 @@
+ >>> text_to_dict('''multiple=1
+ ... multiple= 2
+ ... single =3
+- ... ''')
++ ... ''') # doctest: +SKIP
+ {'single': '3', 'multiple': ['1', '2']}
+
+ """