summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-11-18 21:41:55 -0500
committerMichał Górny <mgorny@gentoo.org>2023-11-19 07:32:17 +0100
commit09a48d7649ff8ec54062a0aa41d675aa3c0e88f9 (patch)
treedfef8f7a82b85150eeb7c209be63da798b5f332f /dev-python/lxml
parentgames-emulation/pcsx2: add 1.7.5214 (diff)
downloadgentoo-09a48d7649ff8ec54062a0aa41d675aa3c0e88f9.tar.gz
gentoo-09a48d7649ff8ec54062a0aa41d675aa3c0e88f9.tar.bz2
gentoo-09a48d7649ff8ec54062a0aa41d675aa3c0e88f9.zip
dev-python/lxml: avoid suppressing compiler warnings
By default, setupinfo.py injects `-w` to the CFLAGS passed down to Extension objects. This obscures things we'd like to see. For example, it prevents adding Modern C Porting flags. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Closes: https://bugs.gentoo.org/917562 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/lxml-4.9.3-r2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/lxml/lxml-4.9.3-r2.ebuild b/dev-python/lxml/lxml-4.9.3-r2.ebuild
index 01ddc28bb840..cd6b75b3c807 100644
--- a/dev-python/lxml/lxml-4.9.3-r2.ebuild
+++ b/dev-python/lxml/lxml-4.9.3-r2.ebuild
@@ -76,6 +76,10 @@ python_prepare_all() {
}
python_compile() {
+ local DISTUTILS_ARGS=(
+ # by default it adds -w to CFLAGS
+ --warnings
+ )
tc-export PKG_CONFIG
distutils-r1_python_compile
}