summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 13:34:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 13:47:04 +0200
commit896273c19146f20e7077796790787062bf29970f (patch)
tree31f1d395f7c903c2f845787100c52c35d32b8db3 /dev-python/lxml
parentdev-python/pillow: Enable py3.11 (diff)
downloadgentoo-896273c19146f20e7077796790787062bf29970f.tar.gz
gentoo-896273c19146f20e7077796790787062bf29970f.tar.bz2
gentoo-896273c19146f20e7077796790787062bf29970f.zip
dev-python/lxml: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/lxml-4.8.0-r1.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-python/lxml/lxml-4.8.0-r1.ebuild b/dev-python/lxml/lxml-4.8.0-r1.ebuild
index 59de9e826e8a..26e673acd7a9 100644
--- a/dev-python/lxml/lxml-4.8.0-r1.ebuild
+++ b/dev-python/lxml/lxml-4.8.0-r1.ebuild
@@ -4,12 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1 optfeature toolchain-funcs
DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="https://lxml.de/ https://pypi.org/project/lxml/ https://github.com/lxml/lxml"
+HOMEPAGE="
+ https://lxml.de/
+ https://pypi.org/project/lxml/
+ https://github.com/lxml/lxml
+"
SRC_URI="https://github.com/lxml/lxml/archive/${P}.tar.gz"
S=${WORKDIR}/lxml-${P}
@@ -20,10 +24,12 @@ IUSE="doc examples +threads test"
RESTRICT="!test? ( test )"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
-RDEPEND="
+DEPEND="
>=dev-libs/libxml2-2.9.12-r2
>=dev-libs/libxslt-1.1.28"
-DEPEND="${RDEPEND}"
+RDEPEND="
+ ${DEPEND}
+"
BDEPEND="
virtual/pkgconfig
dev-python/cython[${PYTHON_USEDEP}]
@@ -35,8 +41,10 @@ BDEPEND="
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
')
)
- test? ( dev-python/cssselect[${PYTHON_USEDEP}] )
- "
+ test? (
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ )
+"
PATCHES=(
"${FILESDIR}"/${PN}-4.6.0-tests-pypy.patch