summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 07:42:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 09:12:15 +0200
commit3e52d5006941315a5da0151edf6ac859eb83858f (patch)
tree64d3a856cd10bcdf760d00a0bb7fe8eef131430d /dev-python/lz4
parentdev-python/pygit2: Bump to 1.10.0 (diff)
downloadgentoo-3e52d5006941315a5da0151edf6ac859eb83858f.tar.gz
gentoo-3e52d5006941315a5da0151edf6ac859eb83858f.tar.bz2
gentoo-3e52d5006941315a5da0151edf6ac859eb83858f.zip
dev-python/lz4: Bump to 4.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lz4')
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-4.0.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 3497fa9f259e..3efbe55c2f4e 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-4.0.1.tar.gz 164309 BLAKE2B 6338c2d74dedf1dc92f455378ef87c691291fdd16faebff8992aa927bf95c707b346af6bb35c512d8095b60a1878615d1081ba64f99c083e580eeacfb5cf11a5 SHA512 caa08a8a531ca2887ce7e596b7a3d9d8f8f2b93c6ea48c3fb0f8bbe6e6f2a18fb6b3c055e57841f8ce74f70367738a28dbb5fb1f07cbf785434642e6034b558e
+DIST lz4-4.0.2.tar.gz 164309 BLAKE2B ea08c9786ee224aaf668a74269413c836a4288ab1a3c27497012621bdda9c8c1729c4cb6ba49cb74e7e5302fabbfddba94f8ed94a9612fdf21018a5cbdc70566 SHA512 f2fdd133b9c7389cd7d45b41e61944093b65bcbf529146740fa3721e683a9b4554166c2ad719298e6153e61facc4a4cb021ffd969cd16d4a5b6555fd8f14728f
diff --git a/dev-python/lz4/lz4-4.0.2.ebuild b/dev-python/lz4/lz4-4.0.2.ebuild
new file mode 100644
index 000000000000..55d987ab74fc
--- /dev/null
+++ b/dev-python/lz4/lz4-4.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+)