summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-04 04:35:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-04 04:48:07 +0200
commit02b59f2debe2f718718adca0f60d72ec623f80a6 (patch)
treed41f75f0559b88687d530f7a26461e0615bb6bfb /dev-python/mapbox-earcut
parentdev-python/moto: Bump to 5.0.12 (diff)
downloadgentoo-02b59f2debe2f718718adca0f60d72ec623f80a6.tar.gz
gentoo-02b59f2debe2f718718adca0f60d72ec623f80a6.tar.bz2
gentoo-02b59f2debe2f718718adca0f60d72ec623f80a6.zip
dev-python/mapbox-earcut: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mapbox-earcut')
-rw-r--r--dev-python/mapbox-earcut/Manifest1
-rw-r--r--dev-python/mapbox-earcut/mapbox-earcut-1.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/mapbox-earcut/Manifest b/dev-python/mapbox-earcut/Manifest
index c972a5a3bb86..ff69070fef8a 100644
--- a/dev-python/mapbox-earcut/Manifest
+++ b/dev-python/mapbox-earcut/Manifest
@@ -1 +1,2 @@
DIST mapbox_earcut_python-1.0.1.gh.tar.gz 11794 BLAKE2B c54c2333ac08f551737ff6ba0e5179464c0330fefeb11e5cff9ad6d3927e8a5d5323cbceffd271a25103e75da44f2a4efa17b8c338f888f69f71ee7bc1e21682 SHA512 cdb32585cbaf74c15e59af0ae70d983dd2f9bc9cfe1b59b3eadc4d442f7d962241854b589a035deae67cacd9334833b911d0981f0d417fe587348fc7d24f0c0a
+DIST mapbox_earcut_python-1.0.2.gh.tar.gz 12488 BLAKE2B c5a3f30f5044380979aa579caef3d1bbe55c650bb04740979723561985d7cddb7e10b85b214363b701a5d0ac0135cc646186d35da9f1b1cac2bcd67374121745 SHA512 5d5a4ceebc2cd7cd6492253445ac1f0cb5d0435d58fd0b08c4d4ba7e33643bdfd4d7db5171eac3ae4ece678957cee61c4c09fd4af0ab8fa500681493bfa36894
diff --git a/dev-python/mapbox-earcut/mapbox-earcut-1.0.2.ebuild b/dev-python/mapbox-earcut/mapbox-earcut-1.0.2.ebuild
new file mode 100644
index 000000000000..31c30e838c06
--- /dev/null
+++ b/dev-python/mapbox-earcut/mapbox-earcut-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P="mapbox_earcut_python-${PV}"
+DESCRIPTION="Python bindings to the mapbox earcut C++ library"
+HOMEPAGE="https://github.com/skogler/mapbox_earcut_python"
+SRC_URI="
+ https://github.com/skogler/mapbox_earcut_python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ dev-python/numpy:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/pybind11-2.12[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md README.md )