summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 06:51:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 07:14:53 +0200
commit40257359db4a9155585c5295ea1935bbc1eb5d47 (patch)
treed4d9853c2b3cbdb0707b48ec6b490e080c242d16 /dev-python/markdown2
parentdev-python/jupyter_client: Bump to 7.4.3 (diff)
downloadgentoo-40257359db4a9155585c5295ea1935bbc1eb5d47.tar.gz
gentoo-40257359db4a9155585c5295ea1935bbc1eb5d47.tar.bz2
gentoo-40257359db4a9155585c5295ea1935bbc1eb5d47.zip
dev-python/markdown2: Bump to 2.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.4.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index a0a1f6484ba4..8ee485446144 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1,2 +1,3 @@
DIST markdown2-2.4.3.tar.gz 102973 BLAKE2B 7a856a9d0bd539e3de1e358aa7d4968aca62b67a30dc64a905633040a6a525b2ac1ec0d4cd7d8d4ed9b38e68e5df3f187cf0f56e1816a4ec10efe4e849356580 SHA512 b5eb5cb6ac52878a224aa6b4642ade86593de5340594271940b3ef25809a9e37b9b3cbb04f4fa9880a50a4fee8ed85c1c6d76b19065b0fd703363faf4d812679
DIST markdown2-2.4.5.tar.gz 109389 BLAKE2B 52ef708f0b6df4d948f909b08a94c584738a34fdfc2c063713eead5b3ab9e657468ad2c112951f3296e167efe52c183997f5102a2dbcef15477de064b16bd89e SHA512 55ff010691110c2f79844031b0d4d7c6982c92dc75a1820e8659be02deeda868aca15931c1060795096e3228e6d451d247addc090f1d4939444331d37d5891c2
+DIST markdown2-2.4.6.tar.gz 118321 BLAKE2B d6d053f9f19da0857664275280c9e12d59da9c88db5643df04c4538b3ac9e24feca66361dd05685b2a0d0281af353324e1b051bc315e78f2be9edb20367fa9be SHA512 4c8dbbfa828e6a01e05e714a5d79f8ec4137e80bbd221251d81fc9185f175dc9ac7ebd7b043d052a4b0c2963715d0d25429a22b2671f1512e92c48177c56e2ea
diff --git a/dev-python/markdown2/markdown2-2.4.6.ebuild b/dev-python/markdown2/markdown2-2.4.6.ebuild
new file mode 100644
index 000000000000..baf14a7088a0
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.4.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+HOMEPAGE="
+ https://github.com/trentm/python-markdown2/
+ https://pypi.org/project/markdown2/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pygments-2.7.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}