summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-04 05:07:50 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-04 05:16:11 +0100
commit96df6a726a134a7fdf459133b35aa4398e12ba42 (patch)
tree360db9a47af9a1b2b2ad55d041d0f5ce8bc6113d /dev-python/mkdocstrings
parentdev-python/jupyter-events: Bump to 0.12.0 (diff)
downloadgentoo-96df6a726a134a7fdf459133b35aa4398e12ba42.tar.gz
gentoo-96df6a726a134a7fdf459133b35aa4398e12ba42.tar.bz2
gentoo-96df6a726a134a7fdf459133b35aa4398e12ba42.zip
dev-python/mkdocstrings: Bump to 0.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocstrings')
-rw-r--r--dev-python/mkdocstrings/Manifest1
-rw-r--r--dev-python/mkdocstrings/mkdocstrings-0.28.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings/Manifest b/dev-python/mkdocstrings/Manifest
index 0333ab0c01a4..ec1b45b9b3fb 100644
--- a/dev-python/mkdocstrings/Manifest
+++ b/dev-python/mkdocstrings/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-0.26.2.tar.gz 92512 BLAKE2B e2ca2ba4d5a8916cdb77efb0db6c0fdc5f8969b27f4b0b5b199873a62c85150b5a0dde45797b48d297e08f9e082c9c5329084feb15379ae0a16821ac11aa3fed SHA512 7ea34df4204ae82faa19ddaf81a073152c57d9ef7f55f8935c1eb1b244ebc6ed749d853c72fd28e69ee5e1aa12ae7a2e4b6fff4f9965856a837d15dd0e2cc11e
+DIST mkdocstrings-0.28.0.tar.gz 3392797 BLAKE2B 9484110f80fa85602f64acd04941db1cebf2ff39d4385559f340d3837347fb51f596b7444e1d5efa26018cf8cfba200892b938c298d76ac169beb67c520b66a4 SHA512 a1dece5b99b4f82faa8b1c02a764252df7102c4e72489cff009388cb90833339c9170517373df7e449df311a5ab7dc4d19821e15a99f295065222db0809379ce
diff --git a/dev-python/mkdocstrings/mkdocstrings-0.28.0.ebuild b/dev-python/mkdocstrings/mkdocstrings-0.28.0.ebuild
new file mode 100644
index 000000000000..5c838ad52d22
--- /dev/null
+++ b/dev-python/mkdocstrings/mkdocstrings-0.28.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatic documentation from sources, for MkDocs"
+HOMEPAGE="
+ https://mkdocstrings.github.io/
+ https://github.com/mkdocstrings/mkdocstrings/
+ https://pypi.org/project/mkdocstrings/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jinja2-2.11.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-1.1[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.5[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-autorefs-1.3[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-get-deps-0.2[${PYTHON_USEDEP}]
+ >=dev-python/pymdown-extensions-6.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/markdown-exec[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings-python[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+# mkdocstrings documentation generation requires several currently
+# unpackaged mkdocs extensions and plug-ins, and this test
+# makes use of mkdocs configuration
+EPYTEST_DESELECT=(
+ tests/test_plugin.py::test_disabling_plugin
+ # WTF, it tries to unlink installed files from installed package?!
+ tests/test_handlers.py::test_extended_templates
+ # Needs unpackaged mkdocs-callouts, mkdocs-literate-nav, and possibly more
+ tests/test_inventory.py::test_sphinx_load_mkdocstrings_inventory_file
+ # Internet
+ tests/test_inventory.py::test_load_inventory
+)
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}