summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-19 20:35:20 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-19 20:37:29 -0400
commite366b80beae12fff4fb03dd0c2b393920b14e7e9 (patch)
treef83f7457e8f9ba3a7a2bb1603b7289af8d398a36 /dev-python/nltk/nltk-3.2.3.ebuild
parentmedia-sound/mpd: version bump to 0.20.8 (diff)
downloadgentoo-e366b80beae12fff4fb03dd0c2b393920b14e7e9.tar.gz
gentoo-e366b80beae12fff4fb03dd0c2b393920b14e7e9.tar.bz2
gentoo-e366b80beae12fff4fb03dd0c2b393920b14e7e9.zip
dev-python/nltk: version bump to 3.2.3
Diffstat (limited to 'dev-python/nltk/nltk-3.2.3.ebuild')
-rw-r--r--dev-python/nltk/nltk-3.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/nltk/nltk-3.2.3.ebuild b/dev-python/nltk/nltk-3.2.3.ebuild
new file mode 100644
index 000000000000..ccf9c62b9c3e
--- /dev/null
+++ b/dev-python/nltk/nltk-3.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy test tk"
+
+RDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# currently requires linguistic data to be downloaded separately
+RESTRICT="test"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}