summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2017-08-19 17:53:12 +0900
committerBenda Xu <heroxbd@gentoo.org>2017-08-19 17:54:25 +0900
commit337507fe19e4acba811d117feb539de94934d405 (patch)
treea7a4c19cfa0cf8c77b629818bde1f32329bfc8d5 /dev-python/notebook
parentkde-frameworks/baloo: Drop slot 4 (diff)
downloadgentoo-337507fe19e4acba811d117feb539de94934d405.tar.gz
gentoo-337507fe19e4acba811d117feb539de94934d405.tar.bz2
gentoo-337507fe19e4acba811d117feb539de94934d405.zip
dev-python/notebook: fix sandbox violation when USE=doc.
Credit: Juergen Rose Bug: 626860 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/files/notebook-5.0.0-example-execution.patch27
-rw-r--r--dev-python/notebook/notebook-5.0.0.ebuild5
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/notebook/files/notebook-5.0.0-example-execution.patch b/dev-python/notebook/files/notebook-5.0.0-example-execution.patch
new file mode 100644
index 000000000000..4516cadf11f6
--- /dev/null
+++ b/dev-python/notebook/files/notebook-5.0.0-example-execution.patch
@@ -0,0 +1,27 @@
+commit db90e16d17acc778efdfff6dca69767b47b60cbd
+Author: Benda Xu <heroxbd@gentoo.org>
+Date: Sat Aug 19 17:31:38 2017 +0900
+
+ d/s/examples/N/Importing Notebooks.ipynb: disable execution.
+
+ This notebook example includes writing to the directory of another
+ module, usually resulting in a doc build failure. Therefore we
+ disable its execution by nbsphinx.
+
+ Closes: #2372
+ See-Also: https://bugs.gentoo.org/show_bug.cgi?id=626860
+
+diff --git a/docs/source/examples/Notebook/Importing Notebooks.ipynb b/docs/source/examples/Notebook/Importing Notebooks.ipynb
+index ee42ad526..d6db5395e 100644
+--- a/docs/source/examples/Notebook/Importing Notebooks.ipynb
++++ b/docs/source/examples/Notebook/Importing Notebooks.ipynb
+@@ -511,6 +511,9 @@
+ ],
+ "metadata": {
+ "gist_id": "6011986",
++ "nbsphinx": {
++ "execute": "never"
++ },
+ "kernelspec": {
+ "display_name": "Python 3",
+ "language": "python",
diff --git a/dev-python/notebook/notebook-5.0.0.ebuild b/dev-python/notebook/notebook-5.0.0.ebuild
index fa4e605c702d..b37ff0df7791 100644
--- a/dev-python/notebook/notebook-5.0.0.ebuild
+++ b/dev-python/notebook/notebook-5.0.0.ebuild
@@ -41,11 +41,12 @@ DEPEND="${RDEPEND}
doc? (
app-text/pandoc
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1[${PYTHON_USEDEP}]
+ dev-python/nbsphinx[${PYTHON_USEDEP}]
)
"
-PATCHES=( "${FILESDIR}/${P}"-setupbase.py.patch )
+PATCHES=( "${FILESDIR}/${P}"-setupbase.py.patch
+ "${FILESDIR}/${P}"-example-execution.patch )
python_prepare_all() {
sed \