summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-09-09 09:41:38 +0200
committerPacho Ramos <pacho@gentoo.org>2021-09-09 09:41:56 +0200
commit58758c908b5e82f020d2b20d3ade5fbbc680cce4 (patch)
treed19dce36469a30f368706a2fb804e31223683545 /dev-python/nototools/nototools-0.2.16.ebuild
parentdev-python/booleanOperations: Support python 3.10 (diff)
downloadgentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.tar.gz
gentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.tar.bz2
gentoo-58758c908b5e82f020d2b20d3ade5fbbc680cce4.zip
dev-python/nototools: Bump to 0.2.16
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/nototools/nototools-0.2.16.ebuild')
-rw-r--r--dev-python/nototools/nototools-0.2.16.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/nototools/nototools-0.2.16.ebuild b/dev-python/nototools/nototools-0.2.16.ebuild
new file mode 100644
index 000000000000..b6b05644a50d
--- /dev/null
+++ b/dev-python/nototools/nototools-0.2.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+MY_PN="notofonttools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlefonts/nototools"
+#SRC_URI="https://github.com/googlefonts/nototools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=media-gfx/scour-0.37
+ >=dev-python/booleanOperations-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/defcon-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# Some tests weren't ported to python3 yet and lots of failures
+RESTRICT="test"
+
+distutils_enable_tests setup.py