summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/oauth2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/oauth2')
-rw-r--r--dev-python/oauth2/Manifest1
-rw-r--r--dev-python/oauth2/files/oauth2-exclude-tests.patch13
-rw-r--r--dev-python/oauth2/metadata.xml8
-rw-r--r--dev-python/oauth2/oauth2-1.5.211-r1.ebuild30
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oauth2/Manifest b/dev-python/oauth2/Manifest
new file mode 100644
index 000000000000..e7e92e1a3a31
--- /dev/null
+++ b/dev-python/oauth2/Manifest
@@ -0,0 +1 @@
+DIST oauth2-1.5.211.tar.gz 18608 SHA256 82a38f674da1fa496c0fc4df714cbb058540bed72a30c50a2e344b0d984c4d21 SHA512 3f5606702d4e305c191c924cab01ee3fc7e170a26460c1d49031e3d9a296b3502d5e18edb1ec0e291abd61797cb47b7b2b8929eff33eb8bc9fd73434b3ab028a WHIRLPOOL bd262f4c6d324c048951addc158485bd81c12125fea8cf59545b2cb31c343c793a91cc892d27baeec54b2c62df818e5cb8e9b10196d4f9860fd6e62a37c7bffe
diff --git a/dev-python/oauth2/files/oauth2-exclude-tests.patch b/dev-python/oauth2/files/oauth2-exclude-tests.patch
new file mode 100644
index 000000000000..e2296d869e93
--- /dev/null
+++ b/dev-python/oauth2/files/oauth2-exclude-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index acc41e1..1efd034 100755
+--- a/setup.py
++++ b/setup.py
+@@ -31,7 +31,7 @@ setup(name=PKG,
+ author="Joe Stump",
+ author_email="joe@simplegeo.com",
+ url="http://github.com/simplegeo/python-oauth2",
+- packages = find_packages(),
++ packages = find_packages(exclude=['tests']),
+ install_requires = ['httplib2'],
+ license = "MIT License",
+ keywords="oauth",
diff --git a/dev-python/oauth2/metadata.xml b/dev-python/oauth2/metadata.xml
new file mode 100644
index 000000000000..b8382a97ef63
--- /dev/null
+++ b/dev-python/oauth2/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">oauth2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oauth2/oauth2-1.5.211-r1.ebuild b/dev-python/oauth2/oauth2-1.5.211-r1.ebuild
new file mode 100644
index 000000000000..e8f27d6e5934
--- /dev/null
+++ b/dev-python/oauth2/oauth2-1.5.211-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for OAuth version 1.0"
+HOMEPAGE="http://pypi.python.org/pypi/oauth2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-exclude-tests.patch" )
+
+python_test() {
+ esetup.py test || die "Tests fail with ${EPYTHON}"
+}