summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 03:35:30 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:35:30 +0200
commitd05e90d0be17a8246a81a09778a663ce7c076cae (patch)
tree7cdbb756b2e295ea7efd423329b19f30e06eb21b /dev-python/oct2py
parentdev-python/oct2py: Remove old (diff)
downloadgentoo-d05e90d0be17a8246a81a09778a663ce7c076cae.tar.gz
gentoo-d05e90d0be17a8246a81a09778a663ce7c076cae.tar.bz2
gentoo-d05e90d0be17a8246a81a09778a663ce7c076cae.zip
dev-python/oct2py: Bump to 5.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/Manifest1
-rw-r--r--dev-python/oct2py/oct2py-5.7.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/oct2py/Manifest b/dev-python/oct2py/Manifest
index a50a8e2e7238..9a3c7ea985a0 100644
--- a/dev-python/oct2py/Manifest
+++ b/dev-python/oct2py/Manifest
@@ -1 +1,2 @@
DIST oct2py-5.7.1.tar.gz 441250 BLAKE2B b0eca421b297ca5495508cfcb75e8c3bd0f53f12ab3c367bfedfd2f0064c7d9874c6cbefa0d9fc7bea3c21865993136707dab3deb8cd442090bc1c9cc5786527 SHA512 e8018b88119a5275061e315ecd37d07284ba674d64d778215378f0f6b60d4a33e503f0d26e1d23fb054974673ade9eeae5b292498f158e0a6d476c0998da5e6e
+DIST oct2py-5.7.2.tar.gz 441373 BLAKE2B afa7a98f6d38120e8028438d243fb2baefaf3cacc00b576f32fbf666f193dad95e8468847859e8405b7796ec2132b99e347f9ea466400307d1d23ce46f9489fc SHA512 f01263d210eab9adb3f69025a2a22efebd0b1a4dff040620fd382752159992d9907451ec7a72c75f211a9a8e18a1d1c53ff5d3512d8bd807afc737b50fcae178
diff --git a/dev-python/oct2py/oct2py-5.7.2.ebuild b/dev-python/oct2py/oct2py-5.7.2.ebuild
new file mode 100644
index 000000000000..79f44327ad13
--- /dev/null
+++ b/dev-python/oct2py/oct2py-5.7.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="
+ https://github.com/blink1073/oct2py
+ https://blink1073.github.io/oct2py/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
+ >=dev-python/octave-kernel-0.34.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-0.17[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # No graphics toolkit available: 743589
+ "oct2py/ipython/tests/test_octavemagic.py::OctaveMagicTest::test_octave_plot"
+)
+
+distutils_enable_sphinx docs/source \
+ dev-python/numpydoc \
+ dev-python/pydata-sphinx-theme \
+ dev-python/myst-parser \
+ dev-python/sphinxcontrib-spelling
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}