summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-11 18:22:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-11 20:20:15 +0000
commitc86f743a40ce02e82f70dd8ef115cb9eee93c0f9 (patch)
tree6bdc92b9fe462d0bd492e7cb0d8a6bad9785b4c4 /dev-python/olefile
parentsci-libs/gsl: version bump (diff)
downloadgentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.tar.gz
gentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.tar.bz2
gentoo-c86f743a40ce02e82f70dd8ef115cb9eee93c0f9.zip
dev-python/olefile: initial import, needed for dev-python/pillow
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/olefile')
-rw-r--r--dev-python/olefile/Manifest1
-rw-r--r--dev-python/olefile/metadata.xml12
-rw-r--r--dev-python/olefile/olefile-0.44.ebuild29
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/olefile/Manifest b/dev-python/olefile/Manifest
new file mode 100644
index 000000000000..ccefb55d7f75
--- /dev/null
+++ b/dev-python/olefile/Manifest
@@ -0,0 +1 @@
+DIST olefile-0.44.tar.gz 57903 SHA256 021fbed5c539881d7f1360fb27e942fdfa7c78006bed39e6cd6f3dd9e7bd68da SHA512 92b6ad1bced5b2c8e5332a01e5a2e59527ec2303046d0babd665b0f02fe56966574eff56619de168c50f1ea40df2e61ce589ee61b634222146d049b129514c65 WHIRLPOOL 518a1a29fd3390f816db85a2de4918aa2f81b9d6402faf1c6b410c88a13402139e560d3564da60c75bfd6eba93f5351d8d69581b5e643d259fb421edae9a18e6
diff --git a/dev-python/olefile/metadata.xml b/dev-python/olefile/metadata.xml
new file mode 100644
index 000000000000..f67f501f4ef3
--- /dev/null
+++ b/dev-python/olefile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">olefile</remote-id>
+ <remote-id type="github">python-imaging/Pillow</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/olefile/olefile-0.44.ebuild b/dev-python/olefile/olefile-0.44.ebuild
new file mode 100644
index 000000000000..5770e4e1899a
--- /dev/null
+++ b/dev-python/olefile/olefile-0.44.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+
+}