summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 10:12:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 10:33:26 +0200
commitae0a2d89ca00587f1e3c6e3f86ba5345fc3180c2 (patch)
tree421a28303e35925c3b5f42164cbfd8cb750233f4 /dev-python/openapi-core
parentdev-python/weasyprint: Remove old (diff)
downloadgentoo-ae0a2d89ca00587f1e3c6e3f86ba5345fc3180c2.tar.gz
gentoo-ae0a2d89ca00587f1e3c6e3f86ba5345fc3180c2.tar.bz2
gentoo-ae0a2d89ca00587f1e3c6e3f86ba5345fc3180c2.zip
dev-python/openapi-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.19.1.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 467de4126317..a6f20fc95c06 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,2 +1 @@
-DIST openapi_core-0.19.1.tar.gz 107802 BLAKE2B c8cd318ab6a88272e45fbff16df7e0cef7d8bab6c7cef8d965443fa0ad7439182bd9639f8a912ad913eb3d7727c4aeb49d576a8721aac1d0ba9423dd344da44d SHA512 861e3793303ec89265be3a0846ad702e321ebc8536497d146ef10a4c9ab54900ad35ee9e90ef42e1f0856da8c0e746471e9820b0ac3e149adaa0b951a66b382f
DIST openapi_core-0.19.2.tar.gz 108121 BLAKE2B 0873ba33c0270babb3c3e626e942fd22fc066f8ef408c6f1cadab8140fdb6284d21a1cb5ed767c7f0f370112a1bb263ac50b340cccfe1cba6da1a0f15a73bbde SHA512 cab2343c61bbb8de048b5e3a53c2d753468f6707f3b4b40ddfee7c3ea6eb0f3beff0aebcad632200a5a4b08e93c620aceda659297756d4f587d11039ede0eefa
diff --git a/dev-python/openapi-core/openapi-core-0.19.1.ebuild b/dev-python/openapi-core/openapi-core-0.19.1.ebuild
deleted file mode 100644
index 6779d832c696..000000000000
--- a/dev-python/openapi-core/openapi-core-0.19.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- <dev-python/asgiref-4[${PYTHON_USEDEP}]
- >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- <dev-python/jsonschema-5[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
- <dev-python/jsonschema-path-0.4[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-path-0.3.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.7[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.8[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.7.1[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
- >=dev-python/aioitertools-0.11.0[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-aiohttp-1.0.4[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # missing dependendencies
- tests/integration/contrib/falcon
- tests/integration/contrib/fastapi
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}