summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-09 23:04:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-10 00:44:40 +0100
commit9ed31aada277b04315128f668469a23fcad1d84d (patch)
tree4763d9c9a3b47acd5f7aef8baee5dfdba865c230 /dev-python/openpyxl
parentdev-python/cfn-python-lint: Bump to 0.47.0 (diff)
downloadgentoo-9ed31aada277b04315128f668469a23fcad1d84d.tar.gz
gentoo-9ed31aada277b04315128f668469a23fcad1d84d.tar.bz2
gentoo-9ed31aada277b04315128f668469a23fcad1d84d.zip
dev-python/openpyxl: Bump to 3.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest1
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 60f580cb512d..f0e0fedf9611 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1 +1,2 @@
DIST openpyxl-3.0.6.tar.bz2 2423464 BLAKE2B 205db09634730a1da6c24bc8c407b2f3deeac712b4c2cbe69796c538c6911ccb3e7e003617ab9563df12a74d6ca9fb2b1b83d8d75f3b91c168d2053a14c15d66 SHA512 6996800c54746dc41b902cbea378181cdab5db916fd6863c673df25f84f71de67019e34d0034231d7c588bf56be3f8e16b3a52c198dcbe74465d0b088090c24a
+DIST openpyxl-3.0.7.tar.bz2 2426608 BLAKE2B 5ce0a34ea4ec8f33da2224555f3d681c4cfa2145f4cba10ed182044e6a6d69ce61c500c51a26db7ded2a3a0e778d0d8e2bd996c3852732f565501f233b145db7 SHA512 bd697c353d0a9fe66a7947dc0f51530b8419e39b36833e5322cca544fafcbd6aba36e42e53c1a1672f44b3940de9b91417bc58955c87257b7b82782c480ef738
diff --git a/dev-python/openpyxl/openpyxl-3.0.7.ebuild b/dev-python/openpyxl/openpyxl-3.0.7.ebuild
new file mode 100644
index 000000000000..8ecd3bf3eba4
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+SRC_URI="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest