summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-28 18:07:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-28 18:07:12 +0200
commit55e78f4ef1ca246c548e5a5a6ec8208cba2911e0 (patch)
tree8b2fb392cc7c2148a61063961fda17cbbbb527f3 /dev-python/opt-einsum
parentdev-python/numexpr: Enable py3.12 (diff)
downloadgentoo-55e78f4ef1ca246c548e5a5a6ec8208cba2911e0.tar.gz
gentoo-55e78f4ef1ca246c548e5a5a6ec8208cba2911e0.tar.bz2
gentoo-55e78f4ef1ca246c548e5a5a6ec8208cba2911e0.zip
dev-python/opt-einsum: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/opt-einsum')
-rw-r--r--dev-python/opt-einsum/opt-einsum-3.3.0-r1.ebuild20
1 files changed, 17 insertions, 3 deletions
diff --git a/dev-python/opt-einsum/opt-einsum-3.3.0-r1.ebuild b/dev-python/opt-einsum/opt-einsum-3.3.0-r1.ebuild
index 32486a84ef90..497f35c0649d 100644
--- a/dev-python/opt-einsum/opt-einsum-3.3.0-r1.ebuild
+++ b/dev-python/opt-einsum/opt-einsum-3.3.0-r1.ebuild
@@ -4,17 +4,31 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="Optimized Einsum: A tensor contraction order optimizer"
-HOMEPAGE="https://pypi.org/project/opt-einsum/"
+HOMEPAGE="
+ https://github.com/dgasmith/opt_einsum/
+ https://pypi.org/project/opt-einsum/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest
+
+src_prepare() {
+ # ancient, broken version
+ rm versioneer.py || die
+ distutils-r1_src_prepare
+}