summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-17 15:41:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-17 16:53:24 -0500
commit7c7e02f1dc84cc6acc657dd024a452250eddd520 (patch)
tree40683fc1847b91666a428a975f5ee0c0a11a025d /dev-python/oslo-cache
parentdev-ml/pcre-ocaml: drop old (diff)
downloadgentoo-7c7e02f1dc84cc6acc657dd024a452250eddd520.tar.gz
gentoo-7c7e02f1dc84cc6acc657dd024a452250eddd520.tar.bz2
gentoo-7c7e02f1dc84cc6acc657dd024a452250eddd520.zip
dev-python/oslo-cache: 2.6.1 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-cache')
-rw-r--r--dev-python/oslo-cache/Manifest1
-rw-r--r--dev-python/oslo-cache/oslo-cache-2.6.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/Manifest b/dev-python/oslo-cache/Manifest
index 50b086580ea6..5924d100dafa 100644
--- a/dev-python/oslo-cache/Manifest
+++ b/dev-python/oslo-cache/Manifest
@@ -1 +1,2 @@
DIST oslo-cache-2.3.0.tar.gz 57209 BLAKE2B aa34c4deb0206c86181e629b1ccedaa3b0b7a503f4648b9ffb23dcba84c98658017a720701176776652a2a58447c54662314dd4853ec6ccf6c2acebb4b559325 SHA512 c3ad9c326fa71985d4546bd20bcb8aa9508808c8eae2a9e3dac1c014d148bfa8f5a847eb2ca8d1a204cce07b6d640f9541491dd41c7c6169e993e408786358af
+DIST oslo-cache-2.6.1.tar.gz 60918 BLAKE2B 89def6f66ccb68e8725571b4f9fcc8a98c8b18dbb23186b1ed3cc09ae02eb786608c744f6ea7022fd3a832d206fe75916f74f2c000125c853993dc95f13da8f3 SHA512 20696d9a9feda9368fc261ccc124ab825b85373b2716110dcab7101346467dbf4d9e8a48b689a76ca837a8c4e97d03476b3573623ac57602f5d0e558110dd551
diff --git a/dev-python/oslo-cache/oslo-cache-2.6.1.ebuild b/dev-python/oslo-cache/oslo-cache-2.6.1.ebuild
new file mode 100644
index 000000000000..eee84e0c657c
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-2.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/dogpile-cache-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-8.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-4.2.0[${PYTHON_USEDEP}]
+"