summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 13:33:59 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 13:33:59 +0200
commita5fb4f4f3002e0ba7216acbe7426242e7762f59e (patch)
tree68082673e01d2ac0920202bb5a33189b760462f3 /dev-python/packaging
parentdev-python/nose_warnings_filters: Remove old (diff)
downloadgentoo-a5fb4f4f3002e0ba7216acbe7426242e7762f59e.tar.gz
gentoo-a5fb4f4f3002e0ba7216acbe7426242e7762f59e.tar.bz2
gentoo-a5fb4f4f3002e0ba7216acbe7426242e7762f59e.zip
dev-python/packaging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-20.1.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index 701b98d5d3c4..eacbd2e8e933 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1 @@
-DIST packaging-20.1.tar.gz 72955 BLAKE2B cd23c407693fcfd62c6fb40d996c3768201535cf6ba6dc825a6ee9e1b456a902aa730d1151e3b4e73fcc1193236dbd5ea9cfe6e17eefbc038d48aed12df9089b SHA512 1d51e81ab8b8c552d880ae3d210fe140835de181b6fcee3eb382f0f1d6a416e9cbdaeb52a81c50c53d2c5f5cdc40ee516f29ced845868a1bf7be3b23433f21d7
DIST packaging-20.3.tar.gz 73015 BLAKE2B 863a04124543d510455ffd6cd6974e7b3ed0c43e02baa5124631e24e7d56017d0289475fbcd9a4f038607c4a13aced32d2b98a82d975903afa154b520feb0019 SHA512 b27ad6f72bfe0965a6e6bff78e4e37d4cbab73dc0a1b019673c85615c9d99edf237effeb9756702c6e8c1575a2d981f6d1af364c73d0a451fbb167d64678630f
diff --git a/dev-python/packaging/packaging-20.1.ebuild b/dev-python/packaging/packaging-20.1.ebuild
deleted file mode 100644
index 046ab3f6ba5d..000000000000
--- a/dev-python/packaging/packaging-20.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Core utilities for Python packages"
-HOMEPAGE="https://github.com/pypa/packaging https://pypi.org/project/packaging/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( Apache-2.0 BSD-2 )"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/pyparsing-2.1.10[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/pretend[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-16.8-distutils.patch"
-)
-
-python_test() {
- pytest --capture=no --strict -vv || die
-}
-
-pkg_preinst() {
- # https://bugs.gentoo.org/585146
- cd "${HOME}" || die
-
- _cleanup() {
- local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
- local egginfo="${ROOT}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
- if [[ -d ${egginfo} ]]; then
- rm -rv "${egginfo}" || die "Failed to remove egg-info directory"
- fi
- }
- python_foreach_impl _cleanup
-}